All systems are operational

Datacenter Amsterdam

Operational

Datacenter Rotterdam

Operational

Hosted Exchange

Operational

Desktop-as-a-Service

Operational

Support systems

Operational

Scheduled Maintenance

Schedule

April 2, 2024 22:00 - 23:00 CEST

Components

Desktop-as-a-Service

Description

We would like to inform you that maintenance is planned for our Desktop-as-a-Service environment. During this maintenance we make several improvements to ensure the security and stability of the platform. The maintenance is scheduled for Tuesday, April 2, 2024 from 22:00 to 23:00. During this maintenance the platform is unavailable. If you have any questions about this maintenance, please feel free to contact the service desk.

External Services

History (Last 30 days)

Planned network maintenancePlanned Maintenance

Description

We would like to inform you that maintenance is planned for our network environment. During this maintenance we make several improvements to ensure the security and stability of the network. The maintenance is scheduled for Wednesday, March 27, 2024 from 23:00 to 00:00. We do not expect any impact from this maintenance. If you have any questions about this maintenance, please feel free to contact the service desk.


Components

Datacenter Amsterdam



Schedule

March 27, 2024 23:00 - March 28, 2024 00:00 CET



March 27, 2024 23:38 CET
[Update] The maintenance has been completed successfully.

March 27, 2024 23:00 CET
[Update] Maintenance Started

March 27, 2024 23:38 CET
[Update] The maintenance has been completed successfully.

Description

We would like to inform you that maintenance is planned for our Hosted Exchange control panel. During this maintenance we make several improvements to ensure the security and stability of the platform. The maintenance is scheduled for Wednesday, March 27, 2024 from 20:00 to 21:00. During maintenance, the control panel will be briefly unavailable several times. If you have any questions about this maintenance, please feel free to contact the service desk.


Components

Hosted Exchange, Support systems



Schedule

March 27, 2024 20:00 - March 27, 2024 21:00 CET



March 27, 2024 20:00 CET
[Update] Maintenance has started.

March 27, 2024 21:12 CET
[Update] The maintenance has been completed successfully.
Hosted Exchange platform disruptionPartial Service Disruption

Incident Status

Partial Service Disruption


Components

Hosted Exchange





March 26, 2024 09:45 CET
[Investigating] We are currently experiencing problems on our Hosted Exchange platform. Our engineers are looking for the cause of the problem. We will keep you informed of the progress via this message. We will provide the next update on the incident within 30 minutes. We appreciate your patience and understanding during this time.

March 26, 2024 10:15 CET
[Identified] Our engineers have found the Hosted Exchange problem and are working on a solution. We will keep you informed of the progress of the disruption. We will post the next update within 30 minutes.

March 26, 2024 10:34 CET
[Resolved] Hereby, we would like to inform you that the network incident has been officially closed. All services are now functioning normally, and operations have resumed without any issues. If you have any questions regarding this incident, please contact our service desk.
Phone system disruptionService Disruption

Incident Status

Service Disruption


Components

Support systems





March 25, 2024 08:46 CET
[Identified] We are currently experiencing problems on our phone system. Our supplier is looking for the cause of the problem. We will keep you informed of the progress via this message.

March 25, 2024 10:33 CET
[Resolved] Hereby, we would like to inform you that the phone system incident has been officially closed. All services are now functioning normally, and operations have resumed without any issues. If you have any questions regarding this incident, please contact our service desk.